Back to overview

Dosespot Latency Issue affecting Cases queue

Oct 17 at 11:26pm CDT
Affected services
API (Production)
DoseSpot (Production)

Resolved
Oct 17 at 11:26pm CDT

A Dosespot issue has greatly increased the latency to call all Dosespot API endpoints, which resulted in increased our latency on encounter-related endpoints.

We'll be issuing a change to further decouple our cases queue from Dosespot but prescription submission will still be impacted until Dosespot fixes the issue on their end.


Update: change has been released. Encounters list and encounter details should be restored.


Update: Dosespot issue have been resolved. Service has been restablished.