Back to overview

Update release taking longer than expected

Aug 19 at 12:25pm CDT
Affected services
API (Production)

Resolved
Aug 19 at 12:25pm CDT

As we publish new changes to our platform, we identified an issue that degraded our database performance unexpectedly. Our team is investigating the issue and it should be resolved in the next few minutes.


We resolved the deadlock affecting our release and changes are now live. Service has been restored successfully.