Back to overview
Resolved
8/12 - API/Webhooks Degradation Due to Database Locking
Aug 12, 2026 at 3:03pm UTC
Affected services
API (Production)
Webhooks Queue (Production)
Resolved
Aug 12, 2026 at 3:03pm UTC
We experienced a period of degraded system performance caused by a database query that blocked other database activity. The system remained available, but some API requests and webhook processing were delayed.
Our team identified and terminated the blocking query, and system performance returned to normal. The platform is currently stable, and we are continuing to monitor it closely while completing a root cause analysis and implementing safeguards to prevent this issue from recurring.
Affected services